mail

Author Topic: No power to fuse  (Read 1240 times)

0 Members and 1 Guest are viewing this topic.

Offline Billman

  • Lurking again
  • Eagle
  • **
  • Posts: 104
  • Thumbs Up 9
No power to fuse
« on: June 09, 2013, 02:13:29 PM »
No power to instrument panel fuse I have checked with a test light and have power to everything but the cluster lights. Can someone please help me find the schematics for an 83 wagon power to the fuse box?
1983 SX4
1983 wagon almost DD
1984 wagon DD
1984 wagon

Offline jspeez13

  • Eagle
  • **
  • Posts: 40
  • Thumbs Up 2
Re: No power to fuse
« Reply #1 on: June 17, 2013, 07:36:01 PM »
I am intrsested in any ideas as have the same problem.  It seems as though there are few fuse locations in my fuse box not getting power.  Dash lights, radia and a few acc. Circuits.. I hope the box isn't f-Ed.

Offline 1985amceagle

  • Eagle
  • **
  • Posts: 80
  • Thumbs Up 5
Re: No power to fuse
« Reply #2 on: June 17, 2013, 08:07:59 PM »
this is for the 88 model year, but it should be close to the same.  good luck finding the category it is in!

http://www.amceaglenest.com/~iowaeagl/guide/index.php?title=1988_Large_Electrical_Schematics_-_Much_applicable_to_other_years.

Offline carnuck

  • AMC Eagle Nest Addicted
  • ********
  • Posts: 1747
  • Thumbs Up 55
  • Near Seattle
    • Virtual Jeep
Re: No power to fuse
« Reply #3 on: June 18, 2013, 12:34:01 AM »
First, is the circuit live always or only with the key? I have replaced so many ignition sliders that I have a spare in my glovebox at all times on trips.
FOR SALE
'87 Comanche 4.0L AW4/NP242 3.73 gears, lifted 5" on near new 33" tires $3500 obo
'82 Eagle Wagon (Brown Betty) 4.2L/727/NP229 and soon 8.25 rear axle and non-vacuum 3.08 front to match. 235/75/15 tires. It's down to minor body work (someone creamed my driver's door but I have another in good shape) almost rust free and interior work (seats are worn and carpet torn). $2000 but about to go up due to more work being done.

Pics of my other for sale stuff http://tinyurl.com/jimsclads

 

Factory power antena does not work. Any ideas?

Started by rollguy

Replies: 5
Views: 1558
Last post August 14, 2011, 09:29:47 AM
by rollguy
main power to park lamps?

Started by kajsdf

Replies: 4
Views: 742
Last post March 30, 2012, 07:42:53 AM
by kajsdf
power mirror schematic

Started by thereverendbill

Replies: 8
Views: 1609
Last post July 05, 2011, 12:47:28 AM
by IRON HORSE
Where do these connections go and what do they power?

Started by 00-711

Replies: 5
Views: 963
Last post June 17, 2013, 12:28:58 PM
by BenM
Gauge package harness at fuse panel

Started by macdude443

Replies: 2
Views: 663
Last post May 13, 2013, 08:23:47 PM
by ammachine390