AMC Eagle Den Forum

The Shop => Gremlins => Topic started by: overtonmike on April 30, 2012, 06:42:34 PM

Title: Frustrated already!
Post by: overtonmike on April 30, 2012, 06:42:34 PM
Hi all,
 :newbie:
Newbie here and unfortunately my first post is a cry for help. I recently purchased a 1984 wagon. The previous owners took pretty good care of it. All that seemed to be wrong with it was the auto trans was slipping. I took it to someone reputable and had it rebuilt (the transmission). Since then it has been great. Passed emmisions with flying colors. My 16 year old daughter has been driving it to school. Of course she hates it! But her wise father knows that later in her life she will appreciate the experience ;D
Now on to the recent problem. Out of the blue it started dying on her. I wish I would have been there when it started but I wasn't. I was able to limp it home with her behind me. She said that it was pouring black smoke out the exhast as we neared home. Next morning it started and ran fine for about a minute and then it started sputtering and died. I'm not much of a mechanic but I have replaced the basic electrical stuff including plugs, wires, distributor cap, rotor, coil and ICM thinking that it was one of these items. Nope it still does the same thing. What do I check now? Any ideas?
thank you all
Title: Re: Frustrated already!
Post by: Prafeston on April 30, 2012, 07:16:13 PM
...and then throw them all away and by GRONK's Motorcraft carb! :)
Title: Re: Frustrated already!
Post by: AMC of Houston on April 30, 2012, 08:46:10 PM
Well, depends on where he lives.   Some areas STILL check for original smog equipment, rather than just check the tailpipe emissions (why is beyond me; but I'm not a bureaucrat!!).

Just about has to be a carb issue due to the "black smoke" comment.   Something stuck on the needle/seat, or plugged bleed idle tubes, or both!!
Title: Re: Frustrated already!
Post by: overtonmike on April 30, 2012, 09:24:43 PM
I am very interested in throwing away all the vacuum lines. Where do I get the Motorcraft carb? I'm not too worried about the smog equipment.
Title: Re: Frustrated already!
Post by: Prafeston on April 30, 2012, 09:26:58 PM
http://forums.amceaglenest.com/index.php?topic=36250.0
Title: Re: Frustrated already!
Post by: overtonmike on April 30, 2012, 10:30:13 PM
Thanks for that. I've read through that thread and I'm ready to get one. I hope that takes care of this mess I'm in. I think it will!
Title: Re: Frustrated already!
Post by: overtonmike on May 01, 2012, 04:12:24 PM
Just ordered the kit from Gronk!! Of course I'm excited!!
Title: Re: Frustrated already!
Post by: Prafeston on May 01, 2012, 04:30:15 PM
Good deal. One of the best things you can do for your rough running old Eagle! :) There are plenty of threads that should help you through the install as well as the instructions aren't specifically written for the Eagle, but for a Jeep.