mail

Author Topic: That crazy ECM  (Read 586 times)

0 Members and 1 Guest are viewing this topic.

Offline 82 amc eagle xchp

  • Eagle
  • **
  • Posts: 41
  • Thumbs Up 2
That crazy ECM
« on: November 18, 2012, 05:13:59 PM »
Hello, I had problems with the Eagle for the last few years that were my falt. but its good now I have all systems working and the bent valves replaced. I took it on a nice long trip 1300+- trip to the Henderson nv. AMO show had no problems got 25 mpg ran around 70 mph down hwy 95. but as soon as I got in a few miles of my house I had a little problem. the spark advance seamed to cut in and out I have to drive up a steep hill. I think mablye my 4hg. and 15 hg. vacum sensers are sticking or it may be a bad ground. when I stoped outside of Reno nv. to get gas I noticed the rpms going up and down slightly It was not from the speed solnoild. but preformance was still good. I did notice that when I droped my friend off thants when it started to ping and have a hard time going up hill pulseing like good,bad,good,bad. up the hill. so I am putting the car away for the winter but I am going to clean all the grounds and try to find bushings change those old out of round tires in the back end. so any ideas?

Offline 82 amc eagle xchp

  • Eagle
  • **
  • Posts: 41
  • Thumbs Up 2
Re: That crazy ECM
« Reply #1 on: November 19, 2012, 10:13:45 PM »
Thanks for the reply, I should see if all the delay valves are working it.To bad it ran so good I did take it out and it runs fine. I am going to get some "LBS" greaseless lubrtcant and spray in side of the valves and work them with a vacum pump to free them up. it works on co co clocks so it should work on plastic wit out guming it up. I will make a device with leds lights to moniter the switchs in action from the drives seat. the car has 250000 now nost things have been overhuled by me.