Author Topic: Sometimes completely gutless at highway speeds, minor surging occasionally....  (Read 1114 times)

0 Members and 1 Guest are viewing this topic.

Offline drock87

  • Eagle
  • **
  • Posts: 110
  • Thumbs Up 3
Note: This does not happen ALL the time, but often enough for me to raise concern.  Also, I am not sure if this is actually transmission related.

Second Preface: My kickdown linkage is basically incomplete. If I do not want my car to shift WAY early, I manually upshift it.  (It will also not downshift by itself obviously without coming to a stop)

Sometimes when driving at highway speeds, I will notice that the car does not want to accelerate (it will maintain about 55).  I can floor the pedal and feels like literally nothing. I know our cars are slow, but highway passing is fine when it is not doing this.  Then, when I come to a stop, first and second feel sluggish too...and my temp will raise slightly (not dangerously though).  Here is the real weird part: if I put the car in park, the car WILL stall if it has been doing this.  Restart--no more problem.

What could this possibly be?  If I replace/repair my kickdown linkage...could that help?  I am MUCH more concerned about keeping my tranny in tip-top shape now that I just replaced my rear end...I cannot afford to replace two out of three of the most expensive parts on the car at this time.

Thanks in advance Nest!
2011 Toyota Camry SE
1985 AMC Eagle Sportwagon

I like to to tell people my Eagle is like a Ferrari. It's quirky, tempermental, border-line exotic, and something you don't see everyday.  See? Makes perfect sense....

Click for Akron, Ohio Forecast" height="90" width="160

Offline drock87

  • Eagle
  • **
  • Posts: 110
  • Thumbs Up 3
Got it. Understood.
2011 Toyota Camry SE
1985 AMC Eagle Sportwagon

I like to to tell people my Eagle is like a Ferrari. It's quirky, tempermental, border-line exotic, and something you don't see everyday.  See? Makes perfect sense....

Click for Akron, Ohio Forecast" height="90" width="160

Offline drock87

  • Eagle
  • **
  • Posts: 110
  • Thumbs Up 3
So that has everything to do with the lack of power, stalling when putting into park, etc?  Also, fluid still looks great and it NEVER does this except at highway speed, so maybe I'll park it until I can get it into a shop to take a peek at what is going on to prevent more issues from occuring
2011 Toyota Camry SE
1985 AMC Eagle Sportwagon

I like to to tell people my Eagle is like a Ferrari. It's quirky, tempermental, border-line exotic, and something you don't see everyday.  See? Makes perfect sense....

Click for Akron, Ohio Forecast" height="90" width="160

Offline carguy87

  • Eagle DL
  • ***
  • Posts: 187
  • Thumbs Up 11
Sounds like a broken torque converter to me.

Offline carnuck

  • AMC Eagle Nest Addicted
  • ********
  • Posts: 1747
  • Thumbs Up 55
  • Near Seattle
    • Virtual Jeep
Sounds like the lockup is staying engaged or teh knock sensor is retarding timing seriously. When passing, try manually going to second gear. I dropped the valve body on mine and plugged off the lockup tube with a ball bearing.
FOR SALE
'87 Comanche 4.0L AW4/NP242 3.73 gears, lifted 5" on near new 33" tires $3500 obo
'82 Eagle Wagon (Brown Betty) 4.2L/727/NP229 and soon 8.25 rear axle and non-vacuum 3.08 front to match. 235/75/15 tires. It's down to minor body work (someone creamed my driver's door but I have another in good shape) almost rust free and interior work (seats are worn and carpet torn). $2000 but about to go up due to more work being done.

Pics of my other for sale stuff http://tinyurl.com/jimsclads

Offline TheWraith

  • Eagle
  • **
  • Posts: 133
  • Thumbs Up 7
Sounds like the lockup is staying engaged...

X 2

Offline drock87

  • Eagle
  • **
  • Posts: 110
  • Thumbs Up 3
I was wondering that too....didn't '85's not have lockup converters though?

Also, it does not do this all the time. I am actually wondering about the timing thing, because off the highway, there is sharp turn with a serious bump in it I go over sometimes by my house. One day it did the same type of thing, and this is 30-35 mph. Again, turn off the car, restart, fine (my local gas station is right there). Huh. Either way, I need to find a linkage kit. Any ideas here? I have not had great luck.
2011 Toyota Camry SE
1985 AMC Eagle Sportwagon

I like to to tell people my Eagle is like a Ferrari. It's quirky, tempermental, border-line exotic, and something you don't see everyday.  See? Makes perfect sense....

Click for Akron, Ohio Forecast" height="90" width="160