mail

Author Topic: Need help with hesitation!  (Read 1674 times)

0 Members and 1 Guest are viewing this topic.

Offline macdude443

  • Eagle DL
  • ***
  • Posts: 201
  • Thumbs Up 11
Need help with hesitation!
« on: June 04, 2013, 08:18:11 PM »
Whenever I step on the gas from a stop, the engine bogs down and almost dies unless you let off the gas and ease into it slowly.  Once your past the rough part, it's fine until you stop again.  I have the 2150 kit installed, all vacuum lines are secure.  I have 20" hg at idle.  I have the return line connected with the check valve installed, 3-way filter, return line at 12 o'clock.  The tank vent is open (will be putting the charcoal canister in tomorrow).  I've adjusted the mixture screws, the curb idle and the float to spec (float to 7/16"... as in, I measured from the top of the bowl to the top of the fuel while the engine was at operating temp, however I shut it off right before so fuel would splash all over).  I have the engine timed to around 9 BTDC.  Curb idle is set to 650rpm while in drive.  Choke is operating correctly and wide open at time of hesitation.

I'm running out of things to check.  Any ideas?

Offline macdude443

  • Eagle DL
  • ***
  • Posts: 201
  • Thumbs Up 11
Re: Need help with hesitation!
« Reply #1 on: June 04, 2013, 08:21:10 PM »
I have also tried the accelerator pump linkage in every setting.  There is no slack in it.  As soon as the throttle is pushed, the accelerator pump begins to squirt gas (you can hear it with the car off).

Offline eagleman

  • Eagle Limited
  • *****
  • Posts: 553
  • Thumbs Up 26
Re: Need help with hesitation!
« Reply #2 on: June 04, 2013, 08:49:30 PM »
Do you have a timing light? If so hook it up and while you rev the engine check to see if your timing is advancing as you rev it.Sounds like you may have a vacumm advance problem. And if  thats ok a would suspect a fuel flow problem.
Turkeys walk.Eagles fly!!!

Offline macdude443

  • Eagle DL
  • ***
  • Posts: 201
  • Thumbs Up 11
Re: Need help with hesitation!
« Reply #3 on: June 05, 2013, 08:10:27 AM »
I'll try that.  I have the vacuum advance plugged off at the moment.  It hesitates either way.  I do have a handheld vacuum pump.  I plan on connecting it to the distributor and checking to see if I can get it to advance that way with the cover off.

Offline macdude443

  • Eagle DL
  • ***
  • Posts: 201
  • Thumbs Up 11
Re: Need help with hesitation!
« Reply #4 on: June 05, 2013, 08:42:27 PM »
I haven't checked the timing yet, but here are some other things I did... I replaced the spark plugs and found the old ones to be brown/black.  The old ones were also gapped at .035.  With the HEI I believe they should be .045.  After replacing them the hesitation decreased noticeably.  I decided to check the ported vacuum on the carb to make sure it was increasing as the accelerator is pushed.  Well, at idle, I have about 15" of vacuum.  I don't think that's right.  I tried to re-adjust the mixture screws but after turning them in and then out 1.5 turns, I couldn't get it to idle smoothly.  It would only idle smoothly around 3.5 turns out.  I left it at that.  Hesitation is still there.

Offline JayRamb

  • Eagle Limited
  • *****
  • Posts: 691
  • Thumbs Up 28
  • An AMC lover since age 8
    • 1967 Rambler Rebel
Re: Need help with hesitation!
« Reply #5 on: June 05, 2013, 09:30:28 PM »
I am going out on a limb here. My Eagle did that too and someone from the forum told me to check the tightness of the manifold. The bolts work there way loose. I snugged them up and it did improve 100%.
Jayson H.
Best HWY Mileage of 87 Eagle:  26.2 MPG

Believer in AMSOIL & Seafoam


1987 Garnet Red Eagle: 64,500 miles
SOLD 1984 Black Eagle Limited w/Tach & gauge cluster: 245,100 miles SOLD
1967 Rambler Rebel 4 Door 290 V8 (original family car) Marina Aqua 136K miles
1967 Rambler Rebel 4 Door 290 V8 parts car in Marina Aqua
2009 Nissan Murano SL

Offline macdude443

  • Eagle DL
  • ***
  • Posts: 201
  • Thumbs Up 11
Re: Need help with hesitation!
« Reply #6 on: June 05, 2013, 11:39:21 PM »
Can't hurt.  Did you just snug them up or did you tighten to a spec'd torque?  I can't find the torque spec at a quick glance.

Offline eagleman

  • Eagle Limited
  • *****
  • Posts: 553
  • Thumbs Up 26
Re: Need help with hesitation!
« Reply #7 on: June 06, 2013, 07:28:35 AM »
Check the first and last studs and be sure they are not busted off. Have seen several where these have busted off. If so could be part of your loss of vacumm and hesitation problem.
Turkeys walk.Eagles fly!!!

Offline DaemonForce

  • Grease Magnet
  • Eagle Sport
  • ****
  • Posts: 442
  • Thumbs Up 8
Re: Need help with hesitation!
« Reply #8 on: June 06, 2013, 02:26:37 PM »
What happens to this behavior when you take off the air cleaner?
1983 Limited
AMC 258C {R2:11.Oct.12}
Carter 2681 {R2:28.Oct.12}
TorqueFlite A998 {R6: -20.Apr.12}
NP129 {R2:28.Apr.12}
M35-273 {???}
Compression: 10.5:1
Corrected Idle: 500RPM

Offline carnuck

  • AMC Eagle Nest Addicted
  • ********
  • Posts: 1747
  • Thumbs Up 55
  • Near Seattle
    • Virtual Jeep
Re: Need help with hesitation!
« Reply #9 on: June 06, 2013, 10:14:14 PM »
If you over tighten the aircleaner you can warp the carb top. 2100s are a little less prone to this. Are you sure it's not a Holley 2 bbl? The vacuum port next to the electric choke should be ported vacuum.
FOR SALE
'87 Comanche 4.0L AW4/NP242 3.73 gears, lifted 5" on near new 33" tires $3500 obo
'82 Eagle Wagon (Brown Betty) 4.2L/727/NP229 and soon 8.25 rear axle and non-vacuum 3.08 front to match. 235/75/15 tires. It's down to minor body work (someone creamed my driver's door but I have another in good shape) almost rust free and interior work (seats are worn and carpet torn). $2000 but about to go up due to more work being done.

Pics of my other for sale stuff http://tinyurl.com/jimsclads

Offline ericarmstrong

  • Eagle Sundaancer
  • ******
  • Posts: 1073
  • Thumbs Up 52
Re: Need help with hesitation!
« Reply #10 on: June 15, 2013, 11:10:43 AM »
That engine likes the timing advanced a little past factory spec. I went through that when programing the timing curves on the TBI it had. It may have something to do with the overbore on the rebuild. I checked every other point of failure (as you have) and finally decided to "listen to the engine". After bumping the timing up a bit it ran with no hesitation and would idle at 400 (if i told it to).  Your running a different fuel system now and it's behavior may have changed, but I figured it was a noteworthy point.
1982 AMC Eagle SX/4